We will continue to monitor, but will mark as resolved.
Posted Sep 02, 2026 - 09:42 BST
Update
"Our telemetry indicates service availability remains stable above 99 percent, and we expect the majority of users should no longer be seeing impact from this issue. Our continued focus is on balancing the implementation of our fixes across remaining portions of affected infrastructure to ensure persistent recovery, with added attention on ensuring withstanding recovery of scenarios dependent on REST and Graph API connection methods."
Posted Sep 02, 2026 - 09:03 BST
Monitoring
According to the latest update from Microsoft - https://x.com/MSFT365Status/status/2094683892871520432 - "Our mitigation actions are continuing to progress within the remaining affected infrastructure. Indications from telemetry remain positive, and we've confirmed service availability is improving. We're entering a period of extended monitoring to ensure a full resolution is achieved."
Posted Sep 02, 2026 - 07:41 BST
Investigating
We are getting reports of issues searching for emails in Outlook, and other issues. Microsoft have acknowledged it as follows and are working to resolve...
Users may be unable to connect to, or experience degraded functionality with Exchange Online ID: EX1464935 Issue type: Incident
Status Service Degradation
Impacted services Exchange Online
Details Title: Users may be unable to connect to, or experience degraded functionality with Exchange Online
User impact: Users may be unable to connect to, or experience degraded functionality with Exchange Online.
More info: More info: Users may experience a variety of symptoms related to this event, including but not limited to:
Delays or failures when sending or receiving email messages.
Authentication-related errors when accessing Exchange Online services.
Difficulties accessing or performing actions within Exchange administration experiences.
Intermittent failures affecting mailbox operations and message delivery workflows.
Current status: We're reviewing service telemetry and diagnostic data to isolate the source of the issue after receiving an increase in user-reported issues affecting Exchange Online. We'll keep refining the 'more info' section as additional impacts are identified.
Scope of impact: This issue may impact users attempting to send or receive email messages through Exchange Online. We're continuing our investigation to determine the full scope of affected scenarios and will provide additional information as it becomes available.